Repos updated, httpd 2.2.15, php 5.2.13, mysql 5.0.91 and more

June 2, 2010 by · 62 Comments 

Enough said.  You know what you've got to do.  Issues in the comments as usual.  If something goes wrong and you've got a large bit of data you'd like to send me, please send it via the comment form on the About page and don't break the site layout by posting it all as a comment.

Also, it might pay to check out my Twitter feed over on the right side-bar.  If you don't you might miss things like updates to this site, my neighbor's house catching on fire this past Saturday and me complaining about various things that annoy me.

Comments

62 Responses to “Repos updated, httpd 2.2.15, php 5.2.13, mysql 5.0.91 and more”
  1. Tobias W. says:

    So far, no problems. Just updated Apache etc.

    Thanks for your work. You should consider adding a Flattr button on your page. Mail me, if you need an invite.

    Cheers,

    Tobias W.

  2. Jason says:

    @Tobias,

    Never heard of it. I just took a look though and it seems to be for European sites. I think I'll pass for now. If people feel like contributing then they can use the "Caffeine Fund" link in the upper right. If not, well, "free as in beer" and that sort of thing...

  3. Andrew B says:

    Hi Jason :)

    Thanks for the update.. great to see your alive and kicking ^_^

  4. Greg Scott says:

    Updates performed. Keep up the good work :-)

    Regards,

    Greg

  5. Jason says:

    BTW, any still having that errmsg.sys issue with MySQL? Try as I could, I never was able to replicate it. My systems always overwrote the old file on upgrade from the stock EL4/5 RPMs to the ones from this repo. I did make a small packaging change though that may help.

  6. todd says:

    Just updated, no problems at all. Thanks for keeping this repo going!

  7. Spaok says:

    Did you not build mysql with SSL support by chance?

    Having issues with it since the update.

  8. Jason says:

    The 5.0.91 packages were built with the same options as my older packages.

  9. Irens says:

    Hi. I have this error:

    --> Finished Dependency Resolution
    php-mssql-5.2.11-jason.1.x86_64 from installed has depsolving problems
    --> Missing Dependency: php-common = 5.2.11-jason.1 is needed by package php-mssql-5.2.11-jason.1.x86_64 (installed)
    Error: Missing Dependency: php-common = 5.2.11-jason.1 is needed by package php-mssql-5.2.11-jason.1.x86_64 (installed)

    Best regards ...

  10. Jason says:

    @Irens,

    An error isn't terribly useful without the command that generated it, information about the platform you're on (RHEL or CentOS, 4 or 5, 32- or 64-bit, etc.).

    That said, that message would make believe that you are trying to only upgrade some of the packages on your system rather than running "yum update".

  11. irens says:

    Hi.

    I remove php-mssql then installed via yum again. I use Centos 5.5 x86_64. It seems to be all ok by now. And yes - prev i ran: yum update -y

    Best regards

  12. josh says:

    Ran yum upgrade mysql-server on CentOS 5.4 and got a string of errors that look like,

    Transaction Check Error:
    file /etc/my.cnf from install of mysql-5.0.91-jason.2.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.3.i386

  13. Jason says:

    You really shouldn't have both 32-bit and 64-bit packages installed. Unless you have some particular need for them, you should remove the 32-bit.

    Also, you shouldn't try and upgrade a single package. Just run "yum update".

  14. Nono says:

    Using your repo since 3 years without problems, just would like to thank you for empowering my lovely CentOS, keep up the excellent work Jason

  15. Pasquale says:

    Transaction Check Error:
    file /usr/share/man/man1/pcregrep.1.gz from install of pcre-8.02-1.jason.1.x86_64 conflicts with file from package pcre-6.6-2.el5_1.7.i386
    file /usr/share/man/man1/pcretest.1.gz from install of pcre-8.02-1.jason.1.x86_64 conflicts with file from package pcre-6.6-2.el5_1.7.i386

    also, my 10 cents: I prefer using "yum update", and sometimes need the 32-bit packages available.

  16. Jason says:

    You van try enabling both the 32-bit and 64-bit packages for EL5 but I've no idea what effect that will have. I don't test them at the same time on the same machine as I don't see any reasons why you'd need both 32-bit and 64-bit components of the LAMP stack.

  17. Jerrod says:

    Worked for me, many thanks!

  18. Don't suppose you can make a 5.3.2 build that emulates your 5.2 build. :)

  19. Jason says:

    @Dathan,

    I could but I won't right now since Zend still hasn't released their decoder for PHP 5.3 w(hich means that commercial apps that rely on it won't work). Once they do I'll likely get to work on it. MySQL 5.1 will probably come at the same time. Both will have fair warning on the site before they are released so that people can disable updates if they really do not want to move forward.

  20. Jorge says:

    I noticed something with this repository, when mod_auth* are installed it will fail to update/install php

    it gives back the missing dependency httpd-mmn and a date,

  21. Jason says:

    EL 4 or 5? 32-bit or 64-bit? My packages include most of the mod_auth modules (as us the case with newer upstream Fedora packages) so you shouldn't actully need most of them installed separately.

  22. Foekie_t says:

    Hi,

    I always have been using your yum... for my php and mysql upgrades, but as I am installing a new dedicated server I am doing all and I am coming up with several issue's all the time. Something is blocking me.. any idea what ? I will try to give as much as info possible like below.

    Centos 5.5, i7 processor, 8 gb ram
    Uname: 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:08:30 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

    1st: Install httpd, gives below error.. ?

    yum install httpd*
    httpd-devel-2.2.3-43.el5.centos.i386 from installed has depsolving problems
    --> Missing Dependency: httpd = 2.2.3-43.el5.centos is needed by package httpd-devel-2.2.3-43.el5.centos.i386 (installed)
    Error: Missing Dependency: httpd = 2.2.3-43.el5.centos is needed by package httpd-devel-2.2.3-43.el5.centos.i386 (installed)

    2nd: yum install mod_perl-devel ( I had to install this because mod security wouldn't get installed... )
    mod_perl-devel-2.0.4-6.el5.i386 from installed has depsolving problems
    --> Missing Dependency: mod_perl = 2.0.4-6.el5 is needed by package mod_perl-devel-2.0.4-6.el5.i386 (installed)
    Error: Missing Dependency: mod_perl = 2.0.4-6.el5 is needed by package mod_perl-devel-2.0.4-6.el5.i386 (installed)

    3rd: I see with the yum installs that somehow the 32 bit and the 64 bits are downloaded.. any idea why ? I didn't follow this at all...

    4rd: adding more to your yum ?
    I was wondering, can you add ffmpeg ( ffmpeg ffmpeg-devel mplayer mencoder flvtool2 ) also to your yum repository ? I am using another one, but would like to keep yours as only one. And maybe something for installing PLESK also on a clean dedicated server ?

    Thanks.

  23. Foekie_t says:

    p.s. my modsecurity error message was as below...

    Stopping httpd: [FAILED]
    Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax error on line 5 of /etc/httpd/conf.d/mod_security.conf: Cannot load /etc/httpd/modules/mod_security2.so into server: /etc/httpd/modules/mod_security2.so: undefined symbol: ap_get_server_banner
    [FAILED]

  24. Jason says:

    @Foekie_t,

    1. This has been covered multiple times, in almost every set of post comments & on the yum repo install page in fact. You cannot use my repo if you have both 32- & 64-bit packages installed. I don't see the point so I don't try and accommodate it. if you require this type of environment then you can try manually enabling my 32-bit & 64-bit repos but I've not tested it.

    2. Same issue as #1

    3. That is your system, not my repo. You have both 32-bit & 64-bit versions of the LAMP stack installed. When you try to update from my 64-bit repo, the 32-bit updates are missing and this causes yum to flake out. This typically occurs if you or your host installed httpd, mysql, etc. from the GUI installer, rather than with yum after the fact. You'll need to remove the 32-bit packages.

    4. If you're looking for an all-in-one repo then you should look at remi, art, or epel. I do the packages involved in a LAMP server.

    Regarding your second comment about mod_security, my package works fine for me. If you're getting that error then you're probably using my mod_security package with someone else's httpd or vice-versa.

  25. Foekie_t says:

    Hi,

    Thanks for the fast reply. I am a newbie in these things, so don't kill me :). I will see what I can do with your reply, maybe I am doing some things in the wrong order :).

    Thanks.

  26. Foekie_t says:

    Hi,

    Ok, got it. It seems that 32 bit is sometimes needed.. and sometimes not :)

    Tja.. 1 more question... after installing mysql, what is my root passwd for this one ? Am I missing something again ?

  27. Jason says:

    If you had mysql installed before then the root password is the same. If you didn't then it's blank.

  28. Guido says:

    Hello,

    i would like to upgrade to php 5.3.x .. What is the best way to get this sorted by yum update php?
    At the moment your repos only give the possibility to upgrade to version 5.2.x ...

    With best regards
    Guido

  29. Jason says:

    Don't upgrade just because it's the newest release. If you don't have an app that requires 5.3, or an app that receives some additional functionality, I'd just ride it out on 5.2.

    That said, back to your question, there's really no way for me to answer that without knowing more about your experience. Part of me wants to say, if you have to ask, you'll probably end up breaking your system, but again...

    Your options are to build from source, build an src.rpm from another distro that includes PHP 5.3, switch to a repo that includes 5.3, or wait for me to build 5.3 (which will happen some time after Zend releases loaders for 5.3). If you really do need to do this now, your best options are to switch to another repo (assuming you haven't used my repo or are willing to uninstall that packages you used from mine) or to build the src.rpm from Fedora (which may require slightly more effort but won't require the install of a bunch of other stuff like a 3rd party repo may).

  30. Foekie_t says:

    Hi,

    I know this is a bit off topic, but so strange as I have installed mysql with your repositary and didn't set a root passwd, but somehow the passwd is set as I am not able to connect as root... Is this because I have installed plesk that the root passwd has been set by plesk ?

    Thanks.

  31. Jason says:

    @Foekie_t,

    The only Plesk servers I've ever used have come with it preinstalled by the host. In those cases the password for MySQL & the Plesk admin password were always the same as the root password.

    If you don't know what the root MySQL password is and do not have another account that has full access to the mysql database (where auth data is kept), then you can start MySQL without the grant tables and then change it.

    http://dev.mysql.com/doc/refman/5.0/en/resetting-permissions.html#resetting-permissions-generic

  32. Hazem says:

    I tried upgrading to php 5.2.13, and followed the instructions to setup yum. and I got these errors:
    Transaction Check Error:
    file /etc/php.d/json.ini from install of php-common-5.2.13-jason.1.x86_64 conflicts with file from package php-pecl-json-1.2.1-4.el5.x86_64
    file /usr/lib64/php/modules/json.so from install of php-common-5.2.13-jason.1.x86_64 conflicts with file from package php-pecl-json-1.2.1-4.el5.x86_64

    Any ideas on that? Here is info about my system:
    rpm -qa |grep php
    php-pdo-5.1.6-27.el5
    php-ldap-5.1.6-27.el5
    php-pear-1.4.9-6.el5
    php-cli-5.1.6-27.el5
    php-5.1.6-27.el5
    php-mysql-5.1.6-27.el5
    php-devel-5.1.6-27.el5
    php-pecl-json-1.2.1-4.el5
    php-common-5.1.6-27.el5

    uname -a
    Linux 2.6.18-164.15.1.el5 #1 SMP Wed Mar 17 11:30:06 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

    cat /etc/redhat-release
    CentOS release 5.4 (Final)

    php -v
    PHP 5.1.6 (cli) (built: Mar 31 2010 02:39:17)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    Thanks!!

  33. Jason says:

    @Hazem,

    You're going to need to remove php-pecl-json (this isn't part of CentOS last time I checked, do you already have a 3rd party repo installed?). That is part of PHP core as of 5.2.0 (in my repo it's part of php-common).

  34. Hazem says:

    Thanks Jason!!! That did it!!! You rock!!!

  35. kelye says:

    Hi Jason !
    Is there a way to change the default ./configure ?
    I need json enabled and php_info() show it's disabled.

    Sorry if it's a trivial question but i'm just a php developer not sysadmin :)

  36. Jason says:

    @kelye,

    Ignore the configure options. JSON is already there; it's part of the php-common package.

  37. Neeru Chhabra says:

    I am installing Drupal and downloaded the php 5.2.13 from your repository. But I need to use mysql too. phpinfo shows that it is compiled with --without_mysql. Would you have a version inyour repository with mysql included.

    It is x86_64 architecture.

    Thankyou.

    neeru

  38. Jason says:

    All the php components that are disabled in the core, cli, & common packages are available through other packages. Need mysql (and mysqli)? Install 'php-mysql'. Need GD? Install 'php-gd'. This is the same way it works in the stock upstream packages.

  39. oli says:

    Since a few days i get the error "Public key for libmcrypt-2.5.8-4.el5.centos.x86_64.rpm is not installed" when i try to update my machines. The key is definately installed, i re-installed it just to make sure, but the error remains. any ideas on that?

    oli

    ps: Thank you for that fine repo, it saved me a lot of work!

  40. Jason says:

    @oli,

    You're getting that error because you don't have the public key for CentOS 5 installed (RHEL user?). I copied that package to my repo from CentOS because they moved it from base to extras (which is disabled by default). Run the following and it should work. In the next batch of updates I'll rebuild and sign it with my key.

    rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-5

  41. oli says:

    thx jason! yes, i'm RHEL user and ofcourse your solution worked like a charme :)

  42. Jason,

    I have centos 5 added your repository and did a yum update. Dependencies seemed fine until
    the very end when I got a:
    Error: Missing Dependency: system-logos >= 7.92.1-1 is needed by package httpd

    I can't find system-logos anywhere.. Is it in the Centos Extras?????

  43. Jason says:

    @Peter,

    Yum install redhat-logos. Bigger question is why it wasn't there in the first place.

  44. Peter Filiberti says:

    Jason,

    This is what I have: redhat-logos.noarch 4.9.99-11.el5.centos base
    Cannot find >= 7.92.1 anywhere.. I found a higher version of fedora-logos. Will that work???
    Any way to include those in your repository?

  45. Jason says:

    @Peter,

    That is really odd because I've not had that issue. All my CentOS 4 and 5 systems have updated just fine. Are you upgrading from the stock packages or an older version of mine?

  46. Peter Filiberti says:

    I'm using Centos 5.2 installed as stock. They all have redhat-logos.noarch
    and when I do a yum checkupdate redhat-logos I get
    redhat-logos.noarch 4.9.99-11.el5.centos base

  47. Peter Filiberti says:

    I did a
    yum deplist httpd.i386 | grep -B1 Unsatisfied
    dependency: system-logos >= 7.92.1-1
    Unsatisfied dependency

    I do have the redhat-logos installed but they are 4.9.99 and for some reason it needs 7.92.1. These are
    all just a bunch of default graphics so I'm not sure why it's so important but anyway. Thanks!

    Peter

  48. Jason says:

    @Peter,

    That is the same version that is on all my systems and it works fine. I'll take a closer look at it this weekend.

  49. Peter Filiberti says:

    Jason, I didn't bother to try and just do a yum update after seeing that the dep was bad I just didn't do it.
    So for the hell of it (and hoping to not have you waste time this weekend) I just did a yum uppdate and
    it worked!! So i don't know what was going on... Sorry for the invonvenience and thanks for this work,
    I'm trying to get the people who test for PCI Compliance to LEAVE ME ALONE!! Is there a donation
    button on your site?

  50. Jason says:

    @Peter,

    Heh, strange. Dependency error but it still installs...

    If you'd like to send me something, feel free to use the link in the upper-right of the site, near the search box.

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!

You must be logged in to post a comment.