httpd 2.2.17, mysql 5.1.52, php 5.2.16 and more…

December 21, 2010 by · 73 Comments 

httpd 2.2.17, mysql 5.1.52, php 5.2.16,  XCache 1.3.1, and APC 3.1.6 (which is FINALLY marked as stable) updates are all published to the regular repo, "yum update" for everyone!

More here tomorrow, I'm tired...

EDIT: Or not, I'm a man of few words.  :)

Comments

73 Responses to “httpd 2.2.17, mysql 5.1.52, php 5.2.16 and more…”
  1. Marco Sanchez says:

    Hello man, this is probably very simple for you but I updated the httpd version from 2.2.16 to 2.2.17 just a couple of days ago and it seems that it made the symlinks to stop working, probably I'm totally confused and the reason is something else but I wanted to ask you if you know something about this since the timing the error presented itself with the update of the httpd package was very peculiar.

    The situation is that a symlink used to work before and not it doesn't, hehe, the webpage that now shows a "file not found error" is: https://www9.eonsecure.com/c4d/

    where c4d is the symlink created to another virtual host.

    the vhost_ssl.conf file contains the following:
    # allow symlinks

    Options +FollowSymLinks +Indexes
    php_admin_flag engine on
    php_admin_flag safe_mode off

    plus some other stuff but I guess the previous chunk is what matters, now, I have checked permissions and everything remains being the same as several days ago so anyway, probably you can give me a hand if this is at all related to the updating process.

    Thanks a lot for all your time and effort in keeping up the repo and replying to all of us

    Regards
    Marco

  2. Jeff says:

    Seems to have worked well for me, thanks for the update!

  3. Rick says:

    I'm a little new at this.

    Using your repository, if I issue a "yum update", what will it update? I want to update php and mysql, maybe more.

    Also, could I update only php and mysql with "yum update php" and "yum update mysql"?

    Thanks.

  4. Jason says:

    @Rick,

    httpd, php, mysql, and a few deps, though it would depend on what you have installed. Why don't you just configure your system, run "yum update", and then tell it "No"? That way you'd know exactly what would be changed.

    No, you can't just update php & mysql, there are deps that need to be filled.

  5. Igal says:

    since update i'm having lots of "Unable to allocate memory for pool" errors on all my sites.
    this maybe related to this bug with PHP and APC:
    http://pecl.php.net/bugs/bug.php?id=16966

    i'm think i'll need to downgrade my php.

  6. Rick says:

    Jason,

    Thanks for your post. Well, I did what you said and ran YUM Update, and then saw that I could answer "N" to essentially not continue updating. Now I just need to make sense of what I was shown by YUM UPDATE. It gave me a bunch of packages set to be updated. Then it gave me a list of items that it was installing or updating. In the summary it said: Install 3 packages, update 116 packages, and remove 0 packages.

    By me answering "N", I assume that it really didn't do anything yet and will not until I say "Y".

    Am I on target with my interpretation?

    You thoughts are appreciated.

  7. Jason says:

    @Igal,

    That link says the warning message shows up when you exhaust the memory allocated to APC. You can do one of a few things that wouldn't involve downgrading. First, you could increase the memory allocation. Second, you could switch to eAccelerator or XCache. Third, you could just ignore it.

    @Rick,

    If you have 116 packages to update then your system hasn't been updated in a while. If you were caught up on the core updates and only went to upgrade using mine you wouldn't have gotten more than a dozen or so. You should probably disable my repo, update your system from the core repos, make sure everything still works, then reenable mine and try again.

  8. bizman says:

    IE setcookie can not work!

    <?php
    echo '';
    if(!$_COOKIE['abc']){
    $time = time()+3000;
    $a = setcookie('abc','1234589',$time,'/');
    echo 'ok';
    }else{
    echo 'read cookies';
    print_r($_COOKIE);
    echo 'read ok';
    }
    ?>

    5.2.14 can work!

  9. Jason says:

    @bizman,

    Some quick Googling on that says it's an IE problem with cookies that have expiration dates. If it works in other browsers than there's nothing wrong with PHP.

  10. michael says:

    out of curiosity, is there a reason why you have php and apache packages, but no mod_fastcgi?

  11. Jason says:

    @michael,

    Because mod_fastcgi isn't part of RHEL or CentOS. I provide updates to core packages.

  12. Jamie says:

    Just posting a quick message to say a big thank you for your wonderful repo. :) Been using it for quite some time and have had absolutely NO issues.

  13. Josh says:

    Thank you so much for running this repo. It saved my bacon last week. Thank you thank you thank you!!

    Hey, I noticed that PHP 5.2.17 was just released. Do you anticipate adding that to your repo soon?

  14. Travis says:

    Hey Jason,
    I'm not one for posting on people's blog but I want to give you my gratitude for your repo! Thanks a million good sir!

  15. Ryan Jones says:

    Great repo, which I only just starting using as I needed a newer version of PHP, I sent $5 dollars your way for coffee.

  16. Harry says:

    Thanks for the share, I appreciate that. I would like to see more such updates in future.

  17. Harry says:

    Well its really a wonderful and sort of unique one, I like the way it has shown the things, its really nice. Thanks a lot for sharing it. I would love to recommend it to others.

  18. Waqas Mazhar says:

    sorry it mean php script not run in cron jobs tab
    Reason usr/bin/php not found plz help me

  19. Jason says:

    @Waqas Mazhar,

    Do you have php-cli installed?

  20. Marco says:

    Anybody else enter:
    yum install php-mysql

    and get this:
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
    ---> Package php-pdo.x86_64 0:5.2.16-jason.1 set to be updated
    --> Finished Dependency Resolution
    php-mysql-5.2.16-jason.1.x86_64 from utterramblings has depsolving problems
    --> Missing Dependency: libmysqlclient.so.16()(64bit) is needed by package php-mysql-5.2.16-jason.1.x86_64 (utterramblings)
    php-mysql-5.2.16-jason.1.x86_64 from utterramblings has depsolving problems
    --> Missing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by package php-mysql-5.2.16-jason.1.x86_64 (utterramblings)
    Error: Missing Dependency: libmysqlclient.so.16()(64bit) is needed by package php-mysql-5.2.16-jason.1.x86_64 (utterramblings)
    Error: Missing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by package php-mysql-5.2.16-jason.1.x86_64 (utterramblings)
    ??

    I have spent more hours on this than anyone would believe. I don't know whether to cry or punch drywall, or both simultaneously : (

    ...but I'm leaning towards both.

  21. Jason says:

    @Marco,

    What MySQL packages installed? If they aren't mine (for 5.1.x) you will have issues.

  22. Marco says:

    Well, I'm just starting with a base Centos 5.5 distro (@ linode) with nothing installed. I even have a lullabot "Drupal Performance & Scalability" video that literally has step-by-step instructions (5 hours worth). They instruct viewers to use your repository at the very start of the tutorial, to install:

    yum install php php-common php-cli php-gd php-mcrypt php-pear php-mhash php-mysql php-xml php-mbstring

    And that's where my journey ends. I can't get further than 20 minutes into the instructions. It seems that my problem is that I don't have mysql 5.1 already installed before trying to installing all those php packages? I had read a comment of yours stating that it's all the current stuff in your repo, or nothing but I still I tried yum installing mysql 5.0, thinking it might become apparent what to do next, but it wasn't.

    Any nudges in the right direction would be ridiculously appreciated. Although the command line is awesome, I feel like a blind man grabbing at things in the dark when trying to set up a proper lamp stack.

  23. Jason says:

    @Marco,

    My newest PHP packages are designed to be used with MySQL 5.1, not 5.0. If yum isn't letting you upgrade mysql and mysql-server to 5.1 then your system probably either has the yum priorities or protectbase plugins, or your system both 32-bit and 64-bit packages installed. If the latter, check my Yum Repository page for a link to the CentOS web site with directions on removing the 32-bit overlap.

  24. Chris says:

    @Marco

    Hi Marco,

    Did you find the solution for the problem you were having? I have the same problem as you do (Lullabot tutorial installing - "Drupal Performance & Scalability" video) but I cannot find a solution. Please let me know if you found something.

    Thanks

  25. James says:

    Hi Jason,

    Thanks for all your hard work on this. It is such a great resource to have these packages available to supplement the perpetually out of date CentOS repo's!

    I hate to even both you with a problem but I can't quite figure out why I get the bellow error. I am not using yum priorities and I have experienced this issue when I already had your packages setup and installed. I can solve the issue by getting the package from your repo manually and installing using wget & yum, but that just makes me confused as to why it doesn't find the package to resolve the deps in the first place. I get this error on the 3 or 4 servers where I already have your repo setup and your PHP packages installed.

    --> Finished Dependency Resolution
    php-cli-5.2.16-jason.1.x86_64 from utterramblings has depsolving problems
    --> Missing Dependency: php-common = 5.2.16-jason.1 is needed by package php-cli-5.2.16-jason.1.x86_64 (utterramblings)
    php-5.2.16-jason.1.x86_64 from utterramblings has depsolving problems
    --> Missing Dependency: php-common = 5.2.16-jason.1 is needed by package php-5.2.16-jason.1.x86_64 (utterramblings)
    poppler-utils-0.5.4-4.4.el5_4.11.x86_64 from installed has depsolving problems
    --> Missing Dependency: poppler = 0.5.4-4.4.el5_4.11 is needed by package poppler-utils-0.5.4-4.4.el5_4.11.x86_64 (installed)
    Error: Missing Dependency: poppler = 0.5.4-4.4.el5_4.11 is needed by package poppler-utils-0.5.4-4.4.el5_4.11.x86_64 (installed)
    Error: Missing Dependency: php-common = 5.2.16-jason.1 is needed by package php-cli-5.2.16-jason.1.x86_64 (utterramblings)
    Error: Missing Dependency: php-common = 5.2.16-jason.1 is needed by package php-5.2.16-jason.1.x86_64 (utterramblings)
    You could try using --skip-broken to work around the problem

  26. Jason says:

    @James,

    What command are you running that results in those errors (you should only be running "yum update", not specifying individual packages). What version of php-common is installed now? Do you have any yum plugins (like priorities or protectbase)?

    As to those other errors, I have no idea what poppler is. That's not something that is part of my repo.

  27. James says:

    Yeah the poppler package is another error external to your repo.

    I am just running yum update but I think the error is mine. I do not think this system was ever successfully updated to using your PHP package like I thought since php is 'php-common-5.1.6-27.el5_5.3'. I jumped the gun since I have seen the same error on a system that I know was updated with your PHP repo but since that isn't the case here that is irrelevant.

    When I delete all the PHP packages on my system and try yum install php using your package repo, I have to download and install the latest php-common before the other php packages will install due to the same depsolving issues which just seems strange since the package is available in your repo but perhaps the install is not meant to be as seamless as the upgrade process. I don't have yum priorities or baseprotect enabled.

  28. irens says:

    Hi.

    PHP 5.2.17 is released.

  29. Farhan says:

    Hi,

    I created repo file, and did a yum update. everything went smoothly, but "php --version" is giving me long list of errors. 'yum list php' shows:
    php.i386 5.2.16-jason.1 installed

    -rwxr-xr-x 1 root root 321179 Dec 17 14:14 bcmath.so

    Errors below (sorry couldnt attach a text file):
    Last 3 lines still showing PHP 5.1.6 that comes with CentOS

    php --version
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/bcmath.so' - /usr/lib/php/modules/bcmath.so: undefined symbol: OnUpdateLongGEZero in Unknown on line 0
    PHP Warning: PHP Startup: dba: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: dbase: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/dom.so' - /usr/lib/php/modules/dom.so: undefined symbol: tsrm_realpath in Unknown on line 0
    PHP Warning: PHP Startup: gd: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: imap: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/json.so' - /usr/lib/php/modules/json.so: undefined symbol: zend_hex_strtod in Unknown on line 0
    PHP Warning: PHP Startup: ldap: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: mbstring: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: mcrypt: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mhash.so' - /usr/lib/php/modules/mhash.so: undefined symbol: ap_php_slprintf in Unknown on line 0
    PHP Warning: PHP Startup: mssql: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: mysql: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mysqli.so' - /usr/lib/php/modules/mysqli.so: undefined symbol: zend_std_get_constructor in Unknown on line 0
    PHP Warning: PHP Startup: ncurses: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: odbc: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: PDO: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_dblib.so' - /usr/lib/php/modules/pdo_dblib.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_mysql.so' - /usr/lib/php/modules/pdo_mysql.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_odbc.so' - /usr/lib/php/modules/pdo_odbc.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_pgsql.so' - /usr/lib/php/modules/pdo_pgsql.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_sqlite.so' - /usr/lib/php/modules/pdo_sqlite.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
    PHP Warning: PHP Startup: pgsql: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: snmp: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/soap.so' - /usr/lib/php/modules/soap.so: undefined symbol: php_gcvt in Unknown on line 0
    PHP Warning: PHP Startup: tidy: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/xmlreader.so' - /usr/lib/php/modules/xmlreader.so: undefined symbol: php_dom_create_object in Unknown on line 0
    PHP Warning: PHP Startup: xmlrpc: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/xmlwriter.so' - /usr/lib/php/modules/xmlwriter.so: undefined symbol: tsrm_realpath in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/xsl.so' - /usr/lib/php/modules/xsl.so: undefined symbol: dom_node_class_entry in Unknown on line 0
    PHP Warning: PHP Startup: zip: Unable to initialize module
    Module compiled with module API=20060613, debug=0, thread-safety=0
    PHP compiled with module API=20050922, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP 5.1.6 (cli) (built: Apr 7 2009 08:00:04)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

  30. Jason says:

    @Farhan

    Sounds like you didn't update all of PHP, just the parent package. What is the output of 'rpm -qa | grep php'?

  31. Farhan says:

    rpm -qa | grep php

    php-pear-Net-URL-1.0.15-1.el5.centos
    php-pear-Date-1.4.7-2.el5.centos
    php-mysql-5.2.16-jason.1
    php-xmlrpc-5.2.16-jason.1
    php-tidy-5.2.16-jason.1
    php-pecl-Fileinfo-1.0.4-3.el5.centos
    php-pear-MDB2-Driver-mysql-1.4.1-3.el5.centos
    php-cli-5.2.16-jason.1
    php-gd-5.2.16-jason.1
    php-pear-1.9.1-1.jason.1
    php-pear-HTTP-Request-1.4.2-1.el5.centos
    php-pear-Mail-Mime-1.4.0-1.el5.centos
    php-common-5.2.16-jason.1
    php-odbc-5.2.16-jason.1
    php-soap-5.2.16-jason.1
    php-dba-5.2.16-jason.1
    php-xml-5.2.16-jason.1
    php-bcmath-5.2.16-jason.1
    php-pear-MDB2-2.4.1-2.el5.centos
    php-pear-DB-1.7.13-1.el5.centos
    php-pecl-memcache-2.2.3-1.el5_2
    php-pear-Log-1.9.13-1.el5.centos
    php-pdo-5.2.16-jason.1
    php-pgsql-5.2.16-jason.1
    php-mcrypt-5.2.16-jason.1
    php-mbstring-5.2.16-jason.1
    php-imap-5.2.16-jason.1
    php-pear-Net-Socket-1.0.8-1.el5.centos
    php-pear-Net-Sieve-1.1.5-2.el5.centos
    php-ncurses-5.2.16-jason.1
    php-mhash-5.2.16-jason.1
    php-pear-File-1.2.2-1.el5.centos
    php-mssql-5.2.16-jason.1
    php-snmp-5.2.16-jason.1
    php-ldap-5.2.16-jason.1

  32. Farhan says:

    i tried 'yum remove php', which doesnt seem to do anything. my website is still working. not sure what to do.

  33. Jason says:

    @Farhan

    What version does the php binary actually report? It looks like you've got a 5.1 php binary with 5.2 modules.

    Does your server have some kind of control panel installed that might have included its own copy of php?

  34. Farhan says:

    I do not think so. I did install Webmin, but i dont think it controls php. At present my server is down, because of php being down, anyone can access my configuration files :( Please help recover.

  35. Farhan says:

    Can you tell me if there is a way to copy php 5.2.16 manually? i have downloaded the source code, am not an an expert otherwise wouldnt go with repos :) or if you can provide a compiled version for centos?

  36. Farhan says:

    ok, so i found two versions. and copied 5.2.16 to the older.
    "cp /usr/bin/php /usr/local/bin/php"

    Seems to be working now, except for 2-3 errors:

    php --version
    PHP Warning: PHP Startup: fileinfo: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP Warning: PHP Startup: memcache: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP 5.2.16 (cli) (built: Dec 17 2010 14:09:03)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

  37. Farhan says:

    additionally i have removed fileinfo and memcache. php errors are gone, but i am not sure what were these two modules doing. pecl and pear dont work either because of path issues. Both trying to find input files in /usr/local/lib/php/ where as they are located in /usr/share/pear/. I dont know how to fix that either. any help?

  38. Jason says:

    @Farhan,

    It sounds like you had an odd version of PHP installed as I've upgraded hundreds of CentOS 5 systems. Try removing any packages relating to PHP an then reinstalling them.

    Beyond that, if you're looking for more help, please use the contact form on my About page. The comments are getting a little cluttered.

  39. George says:

    Marco and for everyone getting
    php-mysql-5.2.16-jason.1.x86_64 from utterramblings has depsolving problems
    erro during Lullabot video:
    nano /etc/yum.repos.d/jasonlitka.repo
    make sure you have following packages:
    includepkgs=php* mysql*
    Then you should be fine

  40. Freezewall says:

    Hi, when you update PHP 5.2.17 ?

  41. Dima Q says:

    eek! php-mysql (or perhaps libmysql) is compiled with latin1 as default charset!
    oh, horror I spent so many hours debugging those ??????!

    ok, it's clearly my fault to expect sanity over compatibilty from centos, as documented here:

    http://bugs.mysql.com/bug.php?id=19292

    still what do you think of patch to read my.cnf in php-mysql? or just swtich over to utf8 altogether?

  42. Alok Vaidya says:

    Hi Jason,

    I downloaded and installed MySQL 5.1.52 from your repository when, I guess, I was having trouble with the installation of phpMyAdmin (Though I am not very sure of this) but our server came to have the most recent MySQL from your repo.

    The trouble now is, I am trying to install bugzilla 4 and it requires certain perl modules, which in turn require mysql-devel. So when I did a "yum install mysql-devel" there are conflicts shown as below:

    Transaction Check Error:
    package mysql-5.1.52-jason.1.x86_64 (which is newer than mysql-5.0.77-4.el5_5.4.i386) is already installed
    package mysql-devel-5.1.52-jason.1.x86_64 (which is newer than mysql-devel-5.0.77-4.el5_5.4.i386) is already installed
    file /etc/my.cnf from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/my_print_defaults.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysql.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/charsets/Index.xml from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/charsets/cp1250.xml from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/czech/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/danish/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/dutch/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/english/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/estonian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/french/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/german/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/greek/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/italian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/japanese/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/korean/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/polish/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/romanian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/russian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/serbian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/slovak/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/spanish/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/swedish/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64
    file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package mysql-5.1.52-jason.1.x86_64

    I searched for the solution on the net, one of which I got was on fedora forum, which said to do a
    rpm -Uvh --force --nodeps on each package listed and downloaded by going to the packages directory of each repo, I did that but bugzilla module check still shows some packages to be installed, I do not know whether the problem was solved by doing the individual rpms, but could you advice on a better way to resolve such an issue

  43. Patrick says:

    Hi Jason,

    any ETA for a newer MySQL version? I discovered that the software I'm using on top of MySQL is affected by a nasty bug in MySQL server versions 5.1.49 through 5.1.52 (current one in your repo). See http://p173.de/gp/index.php?id=7e1bee97ab&view=nl if you're interested in the gory details...

    Thanks for your work!
    Patrick.

  44. Dima Tisnek says:

    I have a memory leak somewhere in httpd/php/xcache/mysql client.
    httpd x86_64 2.217 jason.1 prefork, ssl
    php x86_64 5.2.16 jason.1
    php-xcache x86_64 1.3.1 jason.1
    mysql x86_64 5.1.52 jason.1

  45. Patrick Kaiser says:

    Hi,

    is there any possibilty to get the source rpm's? specially for php-imap?

    thx patrick

  46. Brion Hase says:

    Repository contains httpd-2.2.17-jason.1. According to NVD/CVE, Apache version 2.2.18 and prior is susceptible to a DOS chunking attack, as well as apr/apr-utils 1.4.4 and prior. Any idea when these packages might be updated in the Utter Ramblings repository?

    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-1928
    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-0419

  47. Rob says:

    Hi Jason,

    Thanks for your great work. I have been using your install of apache 2.2.16 for a long time now but now need version 2.2.19 to fix security holes (PCI compliance). Are you planning on releasing a new version or should I look to create my own rpm. This would be a steep learning curve for me!

    Thanks.

  48. ace says:

    Thanks for your great work.. I hope it will work for me. I just want to ask if is there any possibilty to get the source rpm's?

  49. Bob says:

    Hi Jason:

    Thank you, you have made it possible for me to install wordpress with your incredible PHP repository. One of my servers is running CentOS 5, and your PHP 5.2.16 package is exactly what was needed to get WordPress operational.

    I am now attempting to run an instance of DRUPAL on the same server. It requires php 5.XX, which your package provides. However, DRUPAL requires the php-DOM extension to be made active. I have not been able to activate it in php.ini. After some investigation, I discovered that even though I have dom.so on my system, it is not being loaded because of a Configure directive used when the package was compiled. I believe this is so, but I would not bet my pants on it. Here is a snippet from phpinfo (http://createcash.us/phpinfo.php) -- Under "Configure Command" I see:
    '--without-gd' '--disable-dom

    When configuring DRUPAL, it refuses to install complaining that the php-DOM extension is not loaded.

    I may be looking at this wrong, but it appears to me that the php I have installed, which supports WordPress perfectly, is not compatible with DRUPAL 7x.

    Is there a "fix"? Or am I looking at this in an entirely skewed and erroneous manner?

    Best Regards
    Bob

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!

You must be logged in to post a comment.