Upgrading to MySQL 5.0.44 on RHEL and CentOS

July 3, 2007 by · 9 Comments 

Another month brings another version of MySQL under the 'Monthly Rapid Update' program. This one seems to have been hidden from public view on the main MySQL FTP site but the source showed up on a mirror server (thanks Pair.com!) so I've put together my customary binary RPMs for RedHat Enterprise Linux & CentOS 4.

As with all of my releases, all you'll need to do is run a 'yum update' if you're a user of my repository. Those wishing to compile from source can do so with the src.rpm at the bottom of this post but unless you've got a good reason, I wouldn't recommend it because it takes forever and a day for the testing to run to completion and it will fail near the end if you're one of those people that likes to compile as 'root'.

MySQL 5.0.44 Release Notes

Update (9/24/2009): Packages deleted, use the yum repository instead.

Comments

9 Responses to “Upgrading to MySQL 5.0.44 on RHEL and CentOS”
  1. dbembibre says:

    As always thanks a lot Jason for your great job.
    Rebuilded and updates :)

  2. Jacek says:

    Many thanks. All the best, Jacek

  3. Slappy says:

    Jason:

    Thank you for your rpm depository. I wanted to report one small problem, which I haven't figured out yet. It has to do with the file: mod_python-3.2.8-3.1.jason.1.x86_64.rpm.

    When I run yum update, using your repository, I am getting a strange reading of this file. It is showing up as: Package mod_python.x86_64 0:3.2.8-3.1.jason.1 (notice the space, then a 0, followed by a colon). I don't know if it is reading a header file incorrectly or there is some other error. When I attempt to update with this file it produced two dependency errors:
    Error: Missing Dependency: libpython2.3.so.1.0()(64bit) is needed by package mod_python
    Error: Missing Dependency: python-abi = 2.3 is needed by package mod_python] Our server already has newer versions of both these files.

    When I use the file from the Fedora ftp it shows up as: mod_python-3.2.8-3.1.x86_64.rpm
    and simply tells me the package is already installed. I'm new to this updating process, but I thought I'd report my experience, incase there is an error is some file which may be causeing the issue.

    Thanks for your repository in any case. It's the only place where I've seen the MySQL 5.0.44 updates. Most others are still at 5.0.27; a few have 5.0.37; and a couple now have 5.0.41. Yours seems to be the most up to date. Again many thanks.

  4. Slappy says:

    Jason:

    I've thought about the issue I described in my prior note and have some additional information. The file mod_python-3.2.8-3.1.jason.1.x86_64.rpm is listed with the proper syntax in the repository, but when called by yum update, something is transposing the label of the file so it reads with the ".x86" before the version number and it is seperated by a "0:", rather than a "-". I added this to make clear the it seems to be transposing the arch type and the version number and replacing the seperator. Hope that is more clear.
    Again, thanks for your efforts.

  5. Jason says:

    The mod_python 3.2.8 package in my repo was compiled against Python 2.3.4 (the version that comes with EL 4). If you are using a newer version of Python (specifically, newer than 2.3.x) then you may run into problems if there are no compat libs as a part of that newer version.

    My suggestion would be to revert to the standard EL4 version of Python.

  6. Slappy says:

    Hi Jason:

    Our server is already running python 2.4 and the mod_python update attempt puts up an error which reads:
    Error: Missing Dependency: libpython2.3.so.1.0()(64bit) is needed by package mod_python
    Error: Missing Dependency: python-abi = 2.3 is needed by package mod_python]

    But the issue I was attempting to report is that when your file, which is identified on the ftp as: mod_python-3.2.8-3.1.x86_64.rpm is called by yum, it is showing up as:
    mod_python.x86_64 0:3.2.8-3.1.jason.1 with the name mangled. I was simply wondering whether this represents some issue with either the header or spec file.

  7. Jason says:

    That string seems OK to me. It is simply being printed by yum in a different manner than how the file is named. It will not affect your ability to install a package because that is the intended behavior.

    Like I said though, the reason why you can't install my mod_python package is because you are using python 2.4 instead of 2.3. If you want to use my binary package then you'll need to revert to the stock version of Python from EL4.

  8. Jesse says:

    Looks like there is a new version http://dev.mysql.com/doc/refman/5.0/en/releasenotes-cs-5-0-45.html, which has changed since the 5.0.44 release.

  9. Jason says:

    I actually built the 5.0.45 packages last Friday and have been using them since. I simply haven't had the time to post them up in the repo. In any case, they're up there now and I'll get around to posting an article on the update sometime before the end of the day.

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!

 

Note: This post is over 5 years old. You may want to check later in this blog to see if there is new information relevant to your comment.

By submitting a comment here you grant this site a perpetual license to reproduce your words and name/web site in attribution. Use of a non-personal web site or blog in the "Web Site" field and/or leaving a comment that is off-topic or inappropriate may result in the comment being edited or removed at the discretion of the site owner.