Repos updated, httpd 2.2.15, php 5.2.13, mysql 5.0.91 and more

June 2, 2010 by · 62 Comments 

Enough said.  You know what you've got to do.  Issues in the comments as usual.  If something goes wrong and you've got a large bit of data you'd like to send me, please send it via the comment form on the About page and don't break the site layout by posting it all as a comment.

Also, it might pay to check out my Twitter feed over on the right side-bar.  If you don't you might miss things like updates to this site, my neighbor's house catching on fire this past Saturday and me complaining about various things that annoy me.


62 Responses to “Repos updated, httpd 2.2.15, php 5.2.13, mysql 5.0.91 and more”
  1. Ken says:

    Are you considering offering PHP 5.2.14? It claims a reasonable number of fixes, and since it's EOL for the 5.2.x series, seems appealing.

    Thanks for your work.

  2. Jason says:


    PHP 5.2.14 and httpd 2.2.16 will be coming with mysql 5.1.50 on Monday.

    As to finding Zend-encoded scripts, the easiest way to start would be to check your ini files to see if you've got the zend loaders on your system. If you don't, you can stop here. If you do, you'll have to search your PHP files. I believe they all have zend in a comment at the top.

  3. Ken says:

    Thanks for that (now obvious) tip on searching the inis. Duh.

    Can you consider for now or future, compiling PHP --with-pear, or do you already? I ask because Squirrelmail requires it, and I have a dozen or so installs, and a recent "accident", um... lost my pear....anyway, I had to install RoundCube as a workaround, but it's easier to not have to explain changes to end users. Thanks for considering. Is it OK to clutter up your blog with questions like this?

  4. Ken says:

    Hey, sorry. After further investigation, I see pear in your change log, and in the repo. Sorry for the noob query.

  5. emi says:


    can you build please php-zts-5.2.13?

    thank you

    rpm -qa |grep php

  6. Ken says:

    PHP 5.2.14? Is there any status update?

  7. Jason says:


    I've been swamped lately but the updated packages will enter the "Stable" repo on Monday. The company I work for is having a car show tomorrow (Mustangs) so that has occupied my work days, and I'm renovating a couple rooms in my home so that has killed my evenings and weekends.

    If you want to get them now, switch your servers to the "Testing" repo (directions on the Yum Repository page). Nothing will change between the packages there and the ones pushed to the normal repo on Monday.

  8. Ken says:

    Hey, I inadvertently upgraded to PHP 5.2.14 because it was a dependency I didn't notice of php-imap. Unfortunately, it's caused a breakage of my PHP apps that I'd rather not troubleshoot.

    When I try to yum downgrade php.i386, I get "No Match for available package: php-5.1.6-27.el5.i386" - I know that was the default PHP on Centos 5, but I don't see it in my config anywhere. Can I just erase it?

  9. Jason says:


    I provide upgraded versions of httpd, php, and mysql and there enough dependencies between them that using my repo is an all-or-none move. If you can't use PHP 5.2.14 then you'll have to fix your apps (none should break for a minor upgrade like that so there was something wrong to start with) or remove all my packages and then reinstall the stock ones.

  10. Ken says:

    I am sorted now. Rolled back a couple of days, and my host installed the php-imap for 5.2.13. Thanks for your work, Jason.

  11. Marco says:

    Hi, I installed via YUM the php-mysql-5.2.14-jason.1 package, but i still don't have the mysql shared object in the php modules directory and also all the libc pkg are missing .
    I searched other rpm repos and noticed that in the php-mysql pck there weren't included all the dependencies for glibc.
    Do I have to rpm them one by one with their subsequent sub-dependencies ?
    Thx in advance

  12. Marco says:

    sorry, cancel my last question, all the shared objects are in place and i didn't restarted apache before testing.
    my fault.

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!


Note: This post is over 5 years old. You may want to check later in this blog to see if there is new information relevant to your comment.

By submitting a comment here you grant this site a perpetual license to reproduce your words and name/web site in attribution. Use of a non-personal web site or blog in the "Web Site" field and/or leaving a comment that is off-topic or inappropriate may result in the comment being edited or removed at the discretion of the site owner.